VMware su Fedora 6 con kernel 2.6.20

Con l’avvenuto rilascio della versione 2.6.20 del kernel di Linux della Fedora Core, VMware 5.5.3 non si compila più. Come nei casi precedenti, è sufficiente eseguire le seguenti istruzioni, rispondendo yes a tutte le domande dello script runme.pl. Rispondendo yes anche all’ultima domanda, si esegue anche lo script standard di configurazione di vmware.

cd mytmp
curl -O http://ftp.cvut.cz/vmware/vmware-any-any-update109.tar.gz
tar -zxvf vmware-any-any-update109.tar.gz
cd vmware-any-any-update109
su -c ./runme.pl root

20 thoughts on “VMware su Fedora 6 con kernel 2.6.20

  1. Stasera stavo girando oziosamente in rete e mi imbatto nel tuo sito! Bene, mi piace la grafica, il tono che usi – senza contare che poi mi sono fermato qui perché sono anch’io un utente Fedora… Ma il massimo è stato trovare proprio questa news al primo impatto, quando pochi giorni fa mi ero dovuto arenare (causa la mia imperizia) in un ennesimo tentativo di virtualizzazione per sfruttare più adeguatamente la mia Linuxbox! Beh, già che c’ero ho spulciato anche le altre e mi sembrano quasi tutte interessanti (e alla mia portata, che non sono né un informatico, né un ‘geek’). Vai forte Malek, ho sottoscritto il tuo feed e da stasera fai parte delle mie letture (quasi) quotidiane. CIAO
    PS: siccome ho imbastito un po’ di discussioni con altra gente a riguardo su Fedoraonline.it, ne ho fatto una news che ho postato costaggiù, spero non ti dispiaccia (certo, ho messo anche il link al tuo sito alla fine).

  2. @Aiace: troppi complimenti, ora arrossisco. 😉

    Sono anch’io un lettore di fedoraonline.it, grazie per la news.

  3. Pingback: Fedora Italia - Flog » Vmware e kernel 2.6.20 Fedora

  4. scusate sono nuovo nonostante abbia gia perso parecchie ore su fedora .
    scrivendo l’ultima riga su -c ./runme.pl root mi viene il messsaggio

    Unable to open the installer database /etc/vmware/locations in read-mode.

    Execution aborted.

    mi potete dare una mano? considerando che sono ad un livello basso di conoscenza

    thanks!!

  5. @miki: domanda sciocca: hai installato vmware 5.5.3 prima di seguire le istruzioni scritte qui?

  6. no non l’avevo installato..ho seguito le istruzioni e tutto va bene fino a che

    scrivendo l’ultima riga su -c ./runme.pl root mi viene il messsaggio

    Unable to open the installer database /etc/vmware/locations in read-mode.

    Execution aborted.

    …….?

  7. @miki: allora è semplice: PRIMA devi installare vmware 5.5.2, POI devi eseguire le istruzioni.

  8. ciao inanzitutto grazie per la pazienza ma…come si installa vmware 5.5.2,?

  9. Scusate ma cos’e’ sto vmware 5.5.2?
    Io e’ da mesi che uso VMware server 1.0.2 e va tutto bene (a parte i problemi del kernel 2.6.20 facilmente risolvibili)
    Ho virtualizzato di tutto, e tutto funziona con questa versione, tra l’altro liberamente utilizzabile e scaricabile dal seguente link:
    http://register.vmware.com/content/download.html
    http://download3.vmware.com/software/vmserver/VMware-server-1.0.2-39867.i386.rpm

    Esiste una versione migliore? (una 5.5.2?)
    Mi sfugge qualcosa?

    Ciao a tutti e Grazie in anticipo.

    Dario.

  10. @miki e dario: VMware Workstation, arrivato alla versione 5.5.3, è un prodotto commerciale della VMware. Le mie istruzioni riguardavano proprio questo e non VMware Server, che invece è distribuito gratuitamente.

  11. Ok, grazie x la risp.
    Ma immagino facciano le stesse cose no?
    Quale è la differenza sostanziale tra i due?
    A questo punto perchè non utilizzare VMware server al posto di VMware Workstation?

    Ciao e Grazie x l’attenzione.

    Dario

  12. Ringraziando per il prezioso aiuto, trasmetto l’aggiornamento che sono riuscito a trova:

    cd mytmp
    wget http://knihovny.cvut.cz/ftp/pub/vmware/vmware-any-any-update110.tar.gz
    tar -zxvf vmware-any-any-update110.tar.gz
    cd vmware-any-any-update110
    su -c ./runme.pl root

    dopo va lanciato lo script di default
    vmware-config-pl, che viene automaticamente lanciato se si da un yes anche
    all’ultima domanda dello scritp sopra indicato.

  13. ti ringrazio per il prezioso aiuto per l’installazione di vmware server 1.0.3 ma avrei questo problema:
    dopo aver installato la macchina virtuale xp sul host non riesco dalla stessa ad accedere via rete. Mi intendo meglio, se da winxp virtuale faccio un \indirizzo ip host la stessa non accede alle risorse condivise con samba. la cosa strana che facendo un ping…. l’host mi risponde….. ???? molto strano sembra quasi che un qualche cosa firewall…. (ma lo ho disabilitato sull’host linux) blocchi la macchina virtuale….

  14. @guizzo: hai attivato e configurato samba sull’host (la macchina su cui gira vmware)?

  15. ciao, sicuramente si…. con l’opzione share….. in security…. secondo me ho dato dei parametri sbagliati quando lancio il vmware-config.pl ma ho fatto parecchi tentativi ma nulla di fatto…. ciao e grazie

  16. graziegraziegraziegraziegraziegraziegraziegraziegraziegraziegraziegraziegraziegraziegraziegraziegraziegraziegraziegraziegraziegraziegraziegraziegraziegraziegraziegraziegrazie
    graziegraziegraziegraziegraziegraziegraziegraziegraziegraziegraziegraziegraziegraziegraziegraziegraziegraziegraziegraziegraziegraziegraziegraziegraziegraziegraziegraziegrazie

    Ah, dimenticavo:
    GRAZIE!!!!!
    ( a tutti)

I commenti sono chiusi.