Netgear WG111 v2 su Linux

Netgear WG111 v2Dopo anni di onorato servizio ho messo a riposo il vecchio router Netgear DG824M, sostituendolo con un Netgear DG834G (v3), che ho acquistato in una confezione contenente anche la chiavetta USB wireless WG111 (v2). E’ stata una piacevole sorpresa scoprire che funziona perfettamente su Ubuntu Linux 7.10, senza alcun intervento. Un plug & play migliore di windows, che mi avrebbe costretto ad installare i driver PRIMA di collegare la chiavetta.

Annunci

18 thoughts on “Netgear WG111 v2 su Linux

  1. Scusami, ma che chipset utilizza la tua chiavetta USB? Io la mia WG111T ho dovuto farla andare con ndiswrapper…e la cosa ogni tanto mi crea noie. Credo sia un modello (la mia è una Atheros) diverso dalla tua.
    Grazie per la risposta.

    Alex

  2. @AlexTG
    Questo leggo su /var/log/messages quando collego la chiavetta:

    Nov  5 09:42:05 laptop kernel: [ 2886.932000] usb 4-6: new high speed USB device using ehci_hcd and address 2
    Nov  5 09:42:05 laptop kernel: [ 2887.068000] usb 4-6: configuration #1 chosen from 1 choice
    Nov  5 09:42:06 laptop kernel: [ 2887.780000] wiphy0: hwaddr 00:1b:2f:98:24:75, rtl8187 V1 + rtl8225z2
    Nov  5 09:42:06 laptop kernel: [ 2887.780000] usbcore: registered new interface driver rtl8187
    

    Mentre questo è l’output di lsusb:

    malex@laptop:~$ lsusb 
    Bus 003 Device 001: ID 0000:0000  
    Bus 004 Device 002: ID 0846:6a00 NetGear, Inc. WG111 WiFi (v2)
    Bus 004 Device 001: ID 0000:0000  
    Bus 002 Device 001: ID 0000:0000  
    Bus 001 Device 001: ID 0000:0000  
    
  3. ciao! ho letto che a te la chiavetta va senza problemi, però a me firefox ogni tanto si blocca, nel senso che dopo un pò che sono su internet non carica più i siti. a te non è successo niente del genere?

  4. @cerlo
    a me funziona senza problemi. Il blocco di firefox potrebbe non dipendere dalla chiavetta, dovresti provare con un collegamento diverso, magari via cavo.

  5. Anch’io l’ho provata su Mandriva 2008 e va benissimo…..fino a circa 5-6 metri dal Router Netagear DG834G, dopo di che perde sensibilmente forza di connessione pur non disonnettendosi. Da cosa dipende?
    Saluti

  6. @Marcos
    sto scrivendo questo commento da circa 7 metri e due pareti dal router e il segnale è al 62%, almeno così mi mostra l’applet del NetworkManager.

  7. A me, invece, l’applet di NM indica un segnale anche al 75-80%, ma, nonostante tutto, dopo alcuni minuti le pagine non si aprono più con la medesima velocità. In certi casi non si aprono per niente, nonostante apparentemente sia tutto a posto. Non riesco a capirne il motivo.

  8. ciao io con la tua stessa chiavetta non riesco a connettermi ad internet , non la trova, o meglio trova la connessione internet ma al momento della pass e della successiva connessione niente, non riesce a prendere la connessione 😦

  9. Io non riesco a far funzionare la chiavetta sotto Linux (Xubuntu 7.10).
    Sullo stesso Pc e sotto windows xp funziona perfettamente, sotto Linux invece no, non si accende neppure la spia.
    Sapreste indicarmi qualche soluzione.
    Grazie.

  10. @pigiswe, @ascozzi
    A quanto pare esistono diverse varianti della WG111 v2, con id USB diversi e, incredibile, con stesso id USB e chipset diversi.

    @ascozzi
    Anche se a me funziona con i driver di Ubuntu ho provato con ndiswrapper ma non sono riuscito a farla funzionare. Boh.

  11. scusatemi ho problema con NETGEAR wg111 v2 su linux .. cioè ho messo i driver prova a collegarsi ma nn va mi potete aiutare?

  12. @MANU
    Dacci qualche informazione in più: che Linux hai? Cosa mostra il comando lsusb dopo aver inserito la chiavetta? Cosa scrive il sistema in /var/log/messages quando inserisci la chiavetta?

  13. Salve, ho anche io comprato il bundle modem-router / adattatore usb wifi della netgear (su primestore.it se vi può interessare), anche se la versione del router è la v4, il pennino viene riconosciuto sotto ubuntu gutsy da subito, però ho avuto qualche problemino, e magari la mia esperienza può servire ad altri (ma magari sono solo uno sprovveduto): ho usato il driver nativo “rtl8187” e non riuscivo ad effettuare il pairing adattatore / router (ho provato con la wpa2,wpa e infine wep a 128 bit e mi son fermato sulla wep perchè mi seccava fare altre prove), finché non ho spuntato nella sezione “wireless setup” del router la voce “Allow Broadcast of Name (SSI)” (ma magari è essenziale e naturale farlo, io credevo fosse una sicurezza in più non spuntare tale opzione), è l’unica opzione che ho cambiato, nonostante in network manager inserivo correttamente la stringa.
    Fatto questo il router si è connesso praticamente all’istante, l’unico problema che ho notato è che se il router viene spento e riacceso non c’è verso (in verità ho fatto solo 2 prove, i pc ce li ho su 2 piani e non potevo fare avanti e indietro)di riattivare la connessione a meno di riavviare il pc.
    Nell’applet network manager comunque non si distingue la connessione wireless da una normale connessione cablata, non so se è normale.
    Lode a te Malex e a divilinux, senza i vostri 2 articoli non avrei acquistato questo fantastico router

  14. Ciao, a qualcuno funziona la WPA su ubuntu 8.04 (ovviamente wg111v2 e DG834G v3)? Grazie.

  15. funziona perfettamente, devo solo selezionare dai due computerini nella barra in alto la rete wifi che ha rilevato, inserire l’eventuale pass ed il gioco è fatto 🙂

  16. Ciao a tutti, qualcuno può aiutarmi ho dovuto reistallare windows 98SE, ho istallato l’adattatore WG111, se clicco su l’icona si collega al router, ma non riesco a dire a windows 98SE, di utilizzarla per la connessione ad internet.
    Eppure prima della reistallazione di windows mi funzionava perfettamente.
    Qualcuno sa dirmi cosa fare.

I commenti sono chiusi.